We're seeing an increased error rate
Incident Report for Adapty
Postmortem

We've experienced a DDoS attack. TCP connections were flooded; we received 60 times more connections than normal. We use Cloudflare to protect our APIs. But the attacker targeted other ports, therefore, reducing the quota for good requests.
With help from our infrastructure partner, we restricted this traffic and also increased the number of machines that process regular requests.
To prevent this from happening in the future, we will restrict the origin of all incoming requests so we can easily filter/block them.

Posted Feb 13, 2023 - 16:24 UTC

Resolved
This incident has been resolved.
Posted Feb 13, 2023 - 14:47 UTC
Update
All requests are coming through.
Posted Feb 13, 2023 - 14:47 UTC
Update
Looks like the infrastructure team has identified the core of the issue and mitigated it. Less than 15% of the requests are failing.
Posted Feb 13, 2023 - 14:43 UTC
Update
We are continuing to investigate this issue. More than 50% of the requests are failing, making it a major outage.
Posted Feb 13, 2023 - 14:38 UTC
Investigating
We are currently investigating this issue. Some of the requests are not coming through. The data is not affected.
Posted Feb 13, 2023 - 14:26 UTC
This incident affected: API and Dashboard.