Elevated API Errors
Incident Report for Adapty
Postmortem

Our work on improving the monitoring system led to a memory leak in the pods processing events from the SDKs. The problem was detected by monitoring and resolved by rollback.

Posted Feb 03, 2025 - 09:00 UTC

Resolved
This incident has been resolved.
Posted Feb 01, 2025 - 15:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2025 - 14:33 UTC
Update
We are continuing to investigate this issue.
Posted Feb 01, 2025 - 14:18 UTC
Update
We are continuing to investigate this issue.
Posted Feb 01, 2025 - 14:11 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 01, 2025 - 14:07 UTC
This incident affected: API.