Networking issue
Incident Report for Adapty
Postmortem

Hello everyone!

We had a networking issue with one of the main nodes. For some reason, the internal IP address associated with the node became inaccessible. The issue lasted from 11:37:30 to 11:41:00 UTC. It was resolved automatically without any fixes from our side, so we reached out to our infrastructure provider for details.

The issue affected 12% of requests in the period, and due to its nature, we couldn't recreate them later since no requests were received by the server. Fallback paywalls worked as usual, and most requests will be retried automatically by SDK or Apple/Google servers.

We're sorry about this and are considering ways to minimize the impact of such incidents.

Posted Jul 16, 2024 - 12:45 UTC

Resolved
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Jul 16, 2024 - 11:37 UTC